当前位置: 首页 > >

idea Maven项目版本问题报错小结 : Error:java: 错误: 不支持发行版本 5 && Error:java: 不再支持源选项 5 请使用 6 或更高版本

发布时间:

你们是否还在为idea报这两个错而烦恼,不要再去烦恼了,跟着我去解决这两个问题把!


Error:java: 错误: 不支持发行版本 5Error:java: 不再支持源选项 5 请使用 6 或更高版本
在开始用maven部署项目写一些mybatis和spring的小案例时,每一次idea都会给我提示以上错误(以上的两个我都遇到过),以下方案一须每一次运行前都要去改,(不推荐,但也是百度里随处可见的方法。)
方案一:(可以使你熟练掌握版本问题,因为你每一次都要去改)

一、第一大部分
1、file->File?Settings

2、可以直接搜索Maven,找到Runner,注意改成自己的版本,我的是11

3、找到Java Compiler,两处再一次改为自己的版本号,我的是11

二、第二部分
1、File?Project Structure

2、首先检查 Project,老规矩

3、在检查 Modules


注:之前我都是这么做的,但是n次之后我就在想有没有持久一点的办法,请看方案二


方案二:推荐使用

一、我自己使用的方法(快去快去试试吧!)
首先我们找到pom.xml


我们在标签内部插入这么一段代码,记得改你们的版本号(我的是11)





org.apache.maven.plugins
maven-compiler-plugin
3.8.1

11.0
11.0





二、网上是有两端代码的,我用的上一个,这一个你们可以试试(也是在pom.xml中)



UTF-8
UTF-8
11
11
11



好了,我相信你们还会有更好的办法,欢迎留言,以上方法,来自于百度中的方法,总结下来给同样在努力的各位自勉!



友情链接: 时尚网 总结汇报 幼儿教育 小学教育 初中学习资料网